PHP ne s'exécute pas quand j'utilise des Alias

Questions sur le développement PHP.

Modérateur : Modérateurs

benjabievres
Nouveau membre
Messages : 1
Inscription : dim. 27 mai 2012, 22:56

PHP ne s'exécute pas quand j'utilise des Alias

Messagepar benjabievres » dim. 27 mai 2012, 23:20

bonjour,

J'ai un serveur configuré avec un domaine www.monsite.com (vhost) et un répertoire racine dédié "/var/www/vhost/mondomaine.com/httpdocs".
Lorsque je charge une page PHP en utilisant l'url http://www.monsite.com/demo/index.php, ça pointe sur "/var/www/vhost/mondomaine.com/httpdocs/demo/index.php" et le fichier PHP s'exécute correctement.
De plus, le fichier httpd.conf déclare un repertoire par défaut, quand aucun vhost n'est donné dans l'URL. ex: http://91.121.22.33/monfichier.html, le répertoie est "/var/www/html/monfichier.html".

Mais, je voudrais créer un alias pour pointer sur le même répertoire que pour mon nom de domaine, tout en utilisant l'adresse IP.

J'ai modifié le fichier httpd.conf pour créer l'alias:
Alias /demo/ "/var/www/vhosts/mondomaine.com/httpdocs/demo/"

<Directory "/var/www/vhosts/mondomaine.com/httpdocs/demo/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
</Directory>


Quand je tape l'url suivante http://91.121.22.33/index.php, le bon répertoire est trouvé, mais au lieu de s'exécuter, la source de la page est téléchargée.

Y-a-t'il autre chose à configurer pour que PHP s'exécute dans un alias?

Merci d'avance
Cdlt
Ben

Revenir vers « PHP »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités