Activer le mode SSO avec apache

Configuration de Tomcat et ses différents fichiers XML.

Modérateur : Modérateurs

soussou97
Nouveau membre
Messages : 2
Inscription : mer. 19 oct. 2011, 16:03

Activer le mode SSO avec apache

Messagepar soussou97 » mer. 19 oct. 2011, 16:07

Bonjour ;

J'ai essayé de faire fonctionner le mode SSO en utilisant le module apache "mod_auth_sspi.so" mais quand je me connecte, j'ai le message d'erreur
401 Authorization Required
(This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required)


Dans les logs apache :

(OS 1312)Une ouverture de session spécifiée n'existe pas. Elle est peut-être déjà terminée. : user pezj306: authentication failure for "/wordpress/"

Je suis sous WAMP : Apache/2.2.3 (Win32) PHP/5.2.5 mod_auth_sspi/1.0.4

J'ai téléchargé la version "mod_auth_sspi-1.0.4-2.2.2" et mis dans le répertoire : C:\wamp\bin\apache\apache2.2.3\modules

Et modifier le fichier de config "httpd.conf":


Code : Tout sélectionner


 LoadModule sspi_auth_module modules/mod_auth_sspi.so

<Directory "C:/wamp/www/wordpress">
        Options FollowSymLinks
        AllowOverride None
        Order allow,deny
        Allow from all

        Authname "Accès restreint"
        AuthType SSPI
        SSPIAuth On
        SSPIOfferbasic On
        SSPIAuthoritative On
        SSPIBasicPreferred On
        #SSPIDomain On
        require valid-user
</Directory>


Et redémarre les services apache mais sans succès ! A la connexion :

http://localhost/wordpress/ => j'ai l'erreur 401 ?

Merci.

soussou97
Nouveau membre
Messages : 2
Inscription : mer. 19 oct. 2011, 16:03

Re: Activer le mode SSO avec apache

Messagepar soussou97 » jeu. 20 oct. 2011, 16:14

Bjr;

Quelqu'un sait comment supprimer la Popup d'authentification lorsqu'on se connecte au site ?
Normalement je suis censé accèder directement au site : http://localhost/wordpress/ sans aucune authentification mais a chaque nouvelle connexion il me demande toujours une première authenticifiaction via une Popup :

[*] Le site http://localhost demande un nom d'utilisateur et un mot de passe. Le site indique : « Accès restreint » [/*]

Ma configuration est :

Code : Tout sélectionner

<Directory "C:/wamp/www/wordpress">
   Options None
        AllowOverride None
        Order allow,deny
        Allow from all

        Authname "Accès restreint"
        AuthType SSPI
        SSPIAuth On
        SSPIAuthoritative On
        SSPIOfferbasic On
        SSPIBasicPreferred On
        SSPIDomain dc.XXX.fr
        require valid-user
</Directory>


Merci


Revenir vers « Configuration »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités