scrips lancé en tant que www-data avec suexec!

Questions sur la configuration d'Apache, httpd.conf, et les différents modules.

Modérateur : Modérateurs

canaillou2k5
Nouveau membre
Messages : 2
Inscription : mar. 04 oct. 2011, 15:43

scrips lancé en tant que www-data avec suexec!

Messagepar canaillou2k5 » lun. 30 janv. 2012, 15:49

Bonjour, j'ai installer suexec sur mon serveur apache.

Je voudrais lancer une commande en utilisant shell_exec() de php en tant que "serveur" (utlisateur de l'ordi)

Mais lorsque je l'execute mon script est executer en tant que www-data

Voilà mon fichier site-enable:

Code : Tout sélectionner

<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        SuexecUserGroup serveur serveur

        DocumentRoot /var/www
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>


mon suexec:

Code : Tout sélectionner

root@debian5:/# /usr/lib/apache2/suexec -V
 -D SUEXEC_CONFIG_DIR=/etc/apache2/suexec/
 -D AP_GID_MIN=100
 -D AP_LOG_EXEC="/var/log/apache2/suexec.log"
 -D AP_SAFE_PATH="/usr/local/bin:/usr/bin:/bin"
 -D AP_UID_MIN=100


et mon le fichier www-data dans /etc/apache2/suexec/:

Code : Tout sélectionner

/var/www
public_html/cgi-bin


Merci pour l'aide.

Revenir vers « Configuration »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité