Help, j'arrive pas à configurer RewriteRule

Questions sur la configuration d'Apache, httpd.conf, et les différents modules.

Modérateur : Modérateurs

romu
Nouveau membre
Messages : 1
Inscription : mar. 17 janv. 2012, 10:59

Help, j'arrive pas à configurer RewriteRule

Messagepar romu » mar. 17 janv. 2012, 11:14

Bonjour,
Je suis nouveau ici, pour être honnête je pensais arriver à me passer de vous, mais je suis tombé sur un os, alors me voilà :D Je vais donc essayer d'être clair et concis.

Serveur : Ubuntu 10.04 Server + Apache 2.x. Configuration d'Apache de type "VirtualHost" et ça fonctionne plutôt bien jusqu'ici.

Le préalable, avant, j'avais un domaine :

Code : Tout sélectionner

www.toto.com


Maintenant j'ai un domaine :

Code : Tout sélectionner

www.titi.com


J'ai une redirection de domaine (mise en place directement dans les DNS) qui fait ça :

Code : Tout sélectionner

www.toto.com
->

Code : Tout sélectionner

www.titi.com/toto
...à la précision près que le dossier /toto n'existe pas réellement, il pointe vers une page WordPress (c'est le système des permalink). Jusqu'ici tout va bien.

Maintenant j'ai besoin de rediriger des dossiers physiques, des "vrais" dossiers qui existent sur le serveur, et j'ai besoin que la redirection soit :

Code : Tout sélectionner

www.toto.com/banners/...
->

Code : Tout sélectionner

www.titi.com/banners/toto/...


Le "..." voulant dire que tout ce qui vient après reste identique. Pour le moment, j'ai tenté la configuration suivante dans mon fichier /etc/apache2/sites-available/default :

Code : Tout sélectionner

        <Directory /home/runner/www/>
                Options -Indexes FollowSymLinks MultiViews
                AllowOverride All Indexes
                Order allow,deny
                allow from all
                RewriteEngine on
                RewriteBase /
                RewriteRule ^/toto/banners/* /banners/toto/$1 [L]
                RewriteRule ^index\.php$ - [L]
                RewriteCond %{REQUEST_FILENAME} !-f
                RewriteCond %{REQUEST_FILENAME} !-d

                RewriteRule . /index.php [L]


La plupart du code ci-dessus correspond aux "bonnes pratiques" de WordPress, il n'y a que la ligne "RewriteRule ^/toto/banners/* /banners/toto/$1 [L]" qui a été ajoutée pour réaliser mon besoin et...ça marche pas, je pointe vers la page 404 de WordPress. Les dossiers physiques existent bien pourtant. J'ai essayé avec le "^" de tête, sans, avec des "$" à la fin du premier terme, sans, etc...rien ne fonctionne.

Un coup de main ? Merci.

Revenir vers « Configuration »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité