créer un ScriptAlias dans un sous dossier

Questions sur la configuration d'Apache, httpd.conf, et les différents modules.

Modérateur : Modérateurs

nonoseki
Nouveau membre
Messages : 1
Inscription : sam. 31 déc. 2011, 13:59

créer un ScriptAlias dans un sous dossier

Messagepar nonoseki » sam. 31 déc. 2011, 14:22

Bonjour,
je ne trouve pas de solution en ligne à mon soucis.

J'ai créé un VirtualHost vers mon adresse IP 192.168.1.7
un premier administrateur gère l'accès à http://192.168.1.7
un 2ème administrateur gère l'accès à 192.167.1.7/dossier

et je souhaite rendre possible l'accès à un dossier http://192.168.1.7/dossier/cgi-bin
qui contient un petit script CGI : dossiercgi

malheureusement, lorsque je redémarre mon serveur Apache, j'ai l'information :
"[warn] The ScriptAlias directive in /etc/httpd/conf/httpd.conf at line 1178 will probably never match because it overlaps an earlier Alias."

et en tapant l'adresse http://192.168.1.7/dossier/cgi-bin/dossiercgi
j'ai l'erreur 404 not found.

Code : Tout sélectionner

NameVirtualHost 192.168.1.7:80

<VirtualHost 192.168.1.7:80>
   ServerAdmin web@admins
   DocumentRoot /home/nils/web/monip
   ServerName 192.168.1.7
   ErrorLog logs/monip-error_log
   CustomLog logs/monip-access_log common
   <Directory "/home/nils/web/monip">
      Options none
      Authname prive
      AuthType basic
      AuthUserFile /etc/httpd/privilegies
      Require valid-user
      Order allow,deny
      Allow from all
   </Directory>
   alias /dossier "/home/mathieu/web/dossier"
   <Directory /home/mathieu/web/dossier>
      Options none
      Authname prive
      AuthType basic
      AuthUserFile /etc/httpd/privilegies
      Require valid-user
      Order allow,deny
      Allow from all
   </Directory>
   ScriptAlias /dossier/cgi-bin "/var/www/cgi-bin/"
   <Directory /var/www/cgi-bin>
      AllowOverride None
      Options ExecCGI
      Order allow,deny
      Allow from all
   </Directory>
</VirtualHost>


par contre, si je change la ligne ScriptAlias par

Code : Tout sélectionner

ScriptAlias /cgi-bin "/var/www/cgi-bin/"

je redémarre le serveur Apache sans message warning,

en tapant l'adresse http://192.168.1.7/dossier/cgi-bin/dossiercgi
j'ai toujours l'erreur 404 not found.
mais en tapant l'adresse http://192.168.1.7/cgi-bin/dossiercgi
mon script CGI s’exécute.

Comment puis-je faire en sorte que le script CGI "dossiercgi" ne soit lancé qu'à partir de l'adresse http://192.168.1.7/dossier/cgi-bin/dossiercgi ?


J'espère avoir été assez clair avec ma question de débutant, et merci d'avance beaucoup pour l'aide,

et bonnes fêtes ! :D

Bruno

Revenir vers « Configuration »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité