Pb avec admin phpMyAdmin 2.8.1

Questions sur l'installation d'Apache/PHP/MySQL.

Modérateur : Modérateurs

Avatar de l’utilisateur
dadoupipo
Membre avancé
Membre avancé
Messages : 50
Inscription : mer. 01 déc. 2004, 14:39

Pb avec admin phpMyAdmin 2.8.1

Messagepar dadoupipo » jeu. 15 févr. 2007, 19:14

Bonjour

Apache v1.3.33 et php v4.3.10
j'installe mysql v4.1.22 et phpMyAdmin 2.8.1

et j'ai le message d'erreur suivant en voulant me connecter a mysql avec phpMyAdmin

#1251 - Client does not support authentication protocol requested by server; consider upgrading MySQL client


d'apres la doc ce doit etre compatible
You need PHP 4.1.0 and MySQL 3.23.32 for use phpMyAdmin 2.8.1

merci de m'aider svp

Evolution
Conseiller
Conseiller
Messages : 3032
Inscription : lun. 05 janv. 2004, 18:56
Localisation : Lyon

Messagepar Evolution » jeu. 15 févr. 2007, 19:29

Le client mysql fourni avec php 4.3.10 est trop vieux, veuillez mettre à jour PHP ;) ou le recompiler

Avatar de l’utilisateur
dadoupipo
Membre avancé
Membre avancé
Messages : 50
Inscription : mer. 01 déc. 2004, 14:39

Messagepar dadoupipo » jeu. 15 févr. 2007, 22:11

merci pour votre reponse, mais j'hésite car j'ai peur que bons nombre de scripts php ne fonctionnent plus :? et vu le temps que j'y ai passé !!!!
je n'ai pas envie de devoir tout corriger.

phpMyAdmin, n'etant pas obligatoire, je vais voir si je peux tout simplement m'en passer.

sinon, quelle version stable appache, php, mysql, phpmyadmin utiliser, je ferai un essai sur une machine a part...
le systeme que j'utilise est d'une stabilité remarquable, alors j'hésite a le faire évoluer...car j'avait essayé d'autres versions et ça plantait régulierement !!!!

merci encore

Evolution
Conseiller
Conseiller
Messages : 3032
Inscription : lun. 05 janv. 2004, 18:56
Localisation : Lyon

Messagepar Evolution » ven. 16 févr. 2007, 8:05

il suffit de rester dans la même branche de PHP, et de conserver le même php.ini
les scripts fonctionneront ;)

Prenez PHP 4.4.5

Avatar de l’utilisateur
dadoupipo
Membre avancé
Membre avancé
Messages : 50
Inscription : mer. 01 déc. 2004, 14:39

Messagepar dadoupipo » ven. 16 févr. 2007, 9:58

MERCI :D

Avatar de l’utilisateur
dadoupipo
Membre avancé
Membre avancé
Messages : 50
Inscription : mer. 01 déc. 2004, 14:39

Messagepar dadoupipo » mar. 20 févr. 2007, 10:13

bonjour

J'ai donc comme indisué passe a la version php v4.4.5 au lieu de v3.3.10
et mis mysql v4.1.22 et phpadmin 2.9.1
mais j'ai exactement le meme probleme :cry: :cry:

#1251 - Client does not support authentication protocol requested by server; consider upgrading MySQL client

sauriez vous m'aider svp

Evolution
Conseiller
Conseiller
Messages : 3032
Inscription : lun. 05 janv. 2004, 18:56
Localisation : Lyon

Messagepar Evolution » mar. 20 févr. 2007, 10:40

En gardant un PHP 4.x il faudrait recompiler, car le client MySQL est trop vieux
Donc soit recompiler, soit prendre carrément un PHP 5.2.1; mais là c'est une mise à jour majeure

Avatar de l’utilisateur
dexmon
Gourou
Gourou
Messages : 793
Inscription : sam. 18 juin 2005, 9:55
Localisation : /usr/local/apache
Contact :

Messagepar dexmon » mar. 20 févr. 2007, 15:36

dadoupipo a écrit :bonjour

J'ai donc comme indisué passe a la version php v4.4.5 au lieu de v3.3.10
et mis mysql v4.1.22 et phpadmin 2.9.1
mais j'ai exactement le meme probleme :cry: :cry:

#1251 - Client does not support authentication protocol requested by server; consider upgrading MySQL client

sauriez vous m'aider svp


Salut,
un début de réponse : http://www.digitalpeer.com/id/mysql

Avatar de l’utilisateur
dadoupipo
Membre avancé
Membre avancé
Messages : 50
Inscription : mer. 01 déc. 2004, 14:39

Messagepar dadoupipo » dim. 25 févr. 2007, 16:32

MERCI :D :D :D :D

Run mysql and login as root:

mysql -u root -p
Then, paste the following command, editing as necessary, to change the password of the user to the old format.

UPDATE mysql.user
SET password=OLD_PASSWORD('somepassword')
WHERE user='someuser'
AND host='somehost';

After you have set the passwords to the old format, flush the tables.

flush privileges;

ET CA MARCHE !!!!! :D :D :D


Revenir vers « Installation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Bing [Bot] et 1 invité