Installation automatisé sous Linux

Questions sur l'installation d'Apache/PHP/MySQL.

Modérateur : Modérateurs

Avatar de l’utilisateur
foxyfox
Nouveau membre
Messages : 5
Inscription : mar. 24 janv. 2006, 16:42

Messagepar foxyfox » mer. 25 janv. 2006, 10:23

C'est bon j'ai trouer, queje suis bête ^^

Avatar de l’utilisateur
habreza
Membre avancé
Membre avancé
Messages : 56
Inscription : mar. 10 févr. 2004, 12:09

Messagepar habreza » mer. 25 janv. 2006, 14:43

Bonjour tout le monde,

Merci de ce script mais je crois que je n'ai pas bien compris son mode de fonctionnement:

J'ai une Mandriva 2006 où j'avais installé automatiquement: Mysql, php et apache mais à un moment donné il me dit qu'il ne trouve pas libphp5.so, donc j'ai désintallé les trois avec leurs dependencies.

Je me suis donc rué sur l'aubaine que me représente ce script.

et voila ce qu'il me donne:


Lancement de Mysql
./scriptInstall: line 226: /etc/rc.d/init.d/mysql.server: Aucun fichier ou répertoire de ce type

Et du coup quand je fais mysql je n'ai pas le prompt de mysql.
En plus si je tape:

<a href='http://127.0.0.1' target='_blank'>http://127.0.0.1</a>
il m'affiche le message connexion refusée lors de la tentative de contact de 127.0.0.1

Quelqu'un peut m'aider?

Merci

Avatar de l’utilisateur
habreza
Membre avancé
Membre avancé
Messages : 56
Inscription : mar. 10 févr. 2004, 12:09

Messagepar habreza » mer. 25 janv. 2006, 14:55

J'ai redémarré ma machine et j'ai les mêmes messages.

En plus si j'éùets une commande pour voir les rpm installés, il me sort:

[sidi@SICC5 ~]$ rpm -qa | grep -i apache
perl-Apache-Test-1.25-2mdk
[sidi@SICC5 ~]$ rpm -qa | grep -i http
libghttp1-1.0.9-7mdk
[sidi@SICC5 ~]$ rpm -qa | grep -i php
[sidi@SICC5 ~]$ rpm -qa | grep -i mysql
libmysql14-4.1.12-3mdk
perl-DBD-mysql-3.0002-1mdk

Ce qui laisse supposer que rien n'a été installé!

Merci de votre aide :rolleyes:

Avatar de l’utilisateur
Guide_Gnu
Pilier de forum
Pilier de forum
Messages : 1010
Inscription : dim. 07 mars 2004, 17:37
Localisation : Quelques part dans Level3
Contact :

Messagepar Guide_Gnu » mer. 25 janv. 2006, 15:22

Logique, car ce ne sont pas des RPM ;)

Merci ArchY pour ton update, je la met en première page :)
6 ans de serveurs dédiers.
1 ré-installations (vive Gentoo..).
Plus de 10To échanger sur le web !

Avatar de l’utilisateur
habreza
Membre avancé
Membre avancé
Messages : 56
Inscription : mar. 10 févr. 2004, 12:09

Messagepar habreza » mer. 25 janv. 2006, 16:21

Soit Cher Guide Gnu,
En plus tu as raison il a installé mais avec la commande: mysql je n'ai pas de prompt de mysql>
En plus il ne reconnait pas la commande apacheon. Par ailleur il me donne en fin d'install un message inquiétant sur mysql, il est dans mon premter post(2 messages plus haut).

Merci et à bientôt.

Avatar de l’utilisateur
habreza
Membre avancé
Membre avancé
Messages : 56
Inscription : mar. 10 févr. 2004, 12:09

Messagepar habreza » mer. 25 janv. 2006, 16:29

Bonjour,
Je viens de remarquer non sans appréhension :o que dans la rubriques serveurs et services qui nous permet de démarrer/Arrêter les serveurs avec options au démarrage, je ne vois plus le serveur web(httpd) et le serveur BD(mysqld). Au secours les pots!
:unsure:

Avatar de l’utilisateur
habreza
Membre avancé
Membre avancé
Messages : 56
Inscription : mar. 10 févr. 2004, 12:09

Messagepar habreza » jeu. 26 janv. 2006, 12:02

S'il vous plait, où a votre avis il a bien installé mysql puisqu'il m'a dit que je ne peut pas émettre cette commande?:


Lancement de Mysql
./scriptInstall: line 226: /etc/rc.d/init.d/mysql.server: Aucun fichier ou répertoire de ce type


Merci de bien vouloir me donner un coup de pouce!

Avatar de l’utilisateur
habreza
Membre avancé
Membre avancé
Messages : 56
Inscription : mar. 10 févr. 2004, 12:09

Messagepar habreza » ven. 27 janv. 2006, 11:48

Bonjour,

J'arrive à démarrer apache mais pas pour ssl, par ailleurs apache n'est pas configuré pour reconnaitre php et si j'essaie d'ajouter la ligne

LoadModule php5_module        libexec/libphp5.so
Add...


J'ai un message d'erreur!

Pourtant je vois bien qu'il a installé php et mysql qui ne démarre pas.

Merci de me donner un coup de pouce car là j'en suis au point de me demander si je dois réinstaller mandriva de nouveau! :unsure:

Avatar de l’utilisateur
Guide_Gnu
Pilier de forum
Pilier de forum
Messages : 1010
Inscription : dim. 07 mars 2004, 17:37
Localisation : Quelques part dans Level3
Contact :

Messagepar Guide_Gnu » mar. 31 janv. 2006, 15:44

quelles sont les erreurs qui se sont produit durant l'installation?
6 ans de serveurs dédiers.
1 ré-installations (vive Gentoo..).
Plus de 10To échanger sur le web !

Avatar de l’utilisateur
tuxi
Nouveau membre
Messages : 1
Inscription : sam. 11 févr. 2006, 13:58

Messagepar tuxi » sam. 11 févr. 2006, 14:06

Bonjour, et bravo pour ce script !

Je l'ai exécuté sur une RedHat 9 (vierge), et apparament, apache/mysql ne sont pas installés ... :blink:

Code : Tout sélectionner

[root@argon root]# service httpd start
httpd: unrecognized service
[root@argon root]# service mysql.server start
mysql.server: unrecognized service
[root@argon root]#


J'ai cette erreur lorsque le script veut démarrer MySQL :

Code : Tout sélectionner

Lancement de Mysql
./scriptInstall: line 226: /etc/rc.d/init.d/mysql.server: Aucun fichier ou répertoire de ce type


Même sous Webmin, il ne trouve pas les serveurs ...

Quelqu'un a-t-il une idée ? :huh:

Avatar de l’utilisateur
mere-teresa
Nouveau membre
Messages : 5
Inscription : mer. 02 févr. 2005, 21:39

Messagepar mere-teresa » jeu. 09 mars 2006, 12:40

habreza a écrit :Bonjour,

apache n'est pas configuré pour reconnaitre php et si j'essaie d'ajouter la ligne 

LoadModule php5_module        libexec/libphp5.so
Add...


J'ai un message d'erreur!

Pourtant je vois bien qu'il a installé php.

Merci de me donner un coup de pouce car là j'en suis au point de me demander si je dois réinstaller mandriva de nouveau! :unsure:

J'ai le même problème ! (vais peut-être ouvrir un nouveau thread).

Can't locate API module structure in file /etc/httpd/extramodules/mod_php5.so

Avatar de l’utilisateur
samir_100
Nouveau membre
Messages : 3
Inscription : lun. 27 mars 2006, 18:00

Messagepar samir_100 » lun. 27 mars 2006, 18:26

bonjour
je suis un nouveau utilisateur de linux et j'ai un projet (securité des reseaux ad-hoc) a monter sous openssl et je ne sais pas comment faire pour l'installer j'ai trouvé un fichier INSTALL qui guide a l'installation mais le systeme me retourne des erreurs que je ne sais pas pourquoi vu que je suis les directives a la lettre

$ ./config
$ make
$ make test
$ make install


aussi un autre probleme c'est que comment je vais savoir que l'openssl est installe et aussi comment le lancer desolé j'ai trop demander mais c'est que je ne sais rien encore sur linux vu que je suis habitué a travailler avec windows et mon directeur de recherche a imposé linux comme plate forme et aussi si vous savez qu'il y a uen version qui marche sous windows qui marche bien et que je peux convincre avec mon encadrent.

merci a l'avance et j'attends votre reponse

voici les messages d'erreur qui me retourne une fois je mets les commandes et que je n'arrive pas a comprendre:


$ make

bn_prime.c: In function `BN_is_prime_fasttest_ex':
bn_prime.c:264: erreur: « NUMPRIMES » non déclaré (première utilisation dans cette fonction)
bn_prime.c:264: erreur: (Chaque identificateur non déclaré est rapporté une seule fois
bn_prime.c:264: erreur: pour chaque fonction dans laquelle il apparaît.)
bn_prime.c:265: erreur: « primes » non déclaré (première utilisation dans cette fonction)
bn_prime.c: In function `probable_prime':
bn_prime.c:379: erreur: « NUMPRIMES » non déclaré (première utilisation dans cette fonction)
bn_prime.c:386: erreur: « primes » non déclaré (première utilisation dans cette fonction)
bn_prime.c:379: attention : variable inutilisée « mods »
bn_prime.c: In function `probable_prime_dh':
bn_prime.c:430: erreur: « NUMPRIMES » non déclaré (première utilisation dans cette fonction)
bn_prime.c:433: erreur: « primes » non déclaré (première utilisation dans cette fonction)
bn_prime.c: In function `probable_prime_dh_safe':
bn_prime.c:478: erreur: « NUMPRIMES » non déclaré (première utilisation dans cette fonction)
bn_prime.c:483: erreur: « primes » non déclaré (première utilisation dans cette fonction)
make[2]: *** [bn_prime.o] Erreur 1
make[2]: Leaving directory `/usr/local/src/openssl-0.9.8a/crypto/bn'
make[1]: *** [subdirs] Erreur 1
make[1]: Leaving directory `/usr/local/src/openssl-0.9.8a/crypto'
make: *** [build_crypto] Erreur 1


$ make test

collect2: ld a retourné 1 code d'état d'exécution
make[2]: *** [link_app.] Erreur 1
make[2]: Leaving directory `/usr/local/src/openssl-0.9.8a/test'
make[1]: *** [bntest] Erreur 2
make[1]: Leaving directory `/usr/local/src/openssl-0.9.8a/test'
make: *** [tests] Erreur 2

Avatar de l’utilisateur
ArchY
Nouveau membre
Messages : 8
Inscription : mer. 08 juin 2005, 15:05
Localisation : Saint Germain en Laye (78)
Contact :

Messagepar ArchY » ven. 13 avr. 2007, 16:42

Hello

je suis en train de refaire l'installation automatisé de tout ça avec les derniere versiond e tous les différents modules.

Je fait me tests sur une Fedora Core 6

je poste ici le script et tout ce qu'il faut dès que j'ai terminé

Avatar de l’utilisateur
ArchY
Nouveau membre
Messages : 8
Inscription : mer. 08 juin 2005, 15:05
Localisation : Saint Germain en Laye (78)
Contact :

Messagepar ArchY » dim. 15 avr. 2007, 17:15

voila c'est bientot terminé, par contre je n'ai pas encore intégré le SSL, je vais poster un lien pour ceux qui veulent absolument du ssl, ils pourront s'en sortir avec.


Revenir vers « Installation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité