Apache 2 et mod_ssl pour win32

Questions sur l'installation d'Apache/PHP/MySQL.

Modérateur : Modérateurs

Avatar de l’utilisateur
Gandalf
Sorcier des forums
Sorcier des forums
Messages : 2528
Inscription : jeu. 04 déc. 2003, 22:58

Apache 2 et mod_ssl pour win32

Messagepar Gandalf » jeu. 29 juil. 2004, 12:35

Bonjour à tous,

Très motivé ce matin, j'ai décidé d'installer le support SSL dans mon Apache 2 sous Windows.
Bien entendu j'anticipais cela avec pas mal de craintes, dans la mesure où activer le SSL dans Apache 2 sous Windows reste un sujet sensible.

J'ai donc décidé d'attaquer les choses à la barbare :

( tous les fichiers nécessaires à cette install sont ici : <a href='http://www.apachefrance.com/Telechargement/fichiers/mod_ssl-2.0.58-openSSL-0.98a.zip' target='_blank'>http://www.apachefrance.com/Telechargement...0.98.zip</a> )

Etape 1 :

J'ai téléchargé OpenSSL pour windows, de même que les sources d'Apache 2.
J'ai configuré le projet pour Visual C++ de manière à pointer sur OpenSSL, et j'ai joyeusement compilé mod_ssl.so en version optimisée qui va bien :)
Puis j'ai copié ssleay32.dll et libeay32.dll dans c:/windows/system32.
En enfin, j'ai mis mod_ssl.so dans le répertoire des modules d'apache.

Opération réussie en 7 minutes (temps de téléchargement + compilation)

Etape 2 :

J'ai cherché un tuto de configuration de Apache+SSL sur le net, et je suis tombé sur ça : <a href='http://tud.at/programm/apache-ssl-win32-howto.php3' target='_blank'>http://tud.at/programm/apache-ssl-win32-howto.php3</a> du premier coup

franchement pas mal, quoique assez compliqué par rapport à ce que j'ai eu besoin de faire.

Comme un vulgaire mouton, j'ai suivi les instructions à la lettre pour créer mes certificats :

Code : Tout sélectionner

openssl req -config openssl.cnf -new -out serveur.csr
openssl rsa -in privkey.pem -out serveur.key
openssl x509 -in serveur.csr -out serveur.cert -req -signkey serveur.key -days 365

pas de souci en vue

j'ai volontairement évité tout ce qui me parraissait compliqué dans ce tuto.

temps de l'opération : 3 minutes

Etape 3 :

La partie la plus sensible, la configuration d'apache...

1. j'ai copié mes certificats (serveur.key et serveur.cert) dans Apache2/conf/ssl que j'ai créé.

2. j'ai copié ssl.conf (légèrement différent du tuto) dans Apache2/conf

Code : Tout sélectionner

SSLMutex default
SSLRandomSeed startup builtin
SSLSessionCache none


3. j'ai modifié httpd.conf :

Code : Tout sélectionner

LoadModule ssl_module modules/mod_ssl.so

par défaut, ssl.conf est inclus par httpd.conf dès que mod_ssl est activé.

Code : Tout sélectionner

NameVirtualHost *:443
Listen 443
<VirtualHost *:443>
   CustomLog logs/ssl-access.log common
   ErrorLog logs/ssl-error.log

   SSLEngine On
   SSLCertificateFile conf/ssl/serveur.cert
   SSLCertificateKeyFile conf/ssl/serveur.key

   ServerName serveur

   DocumentRoot "D:/Sites/test"

   <Directory "D:/Sites/test">
  AllowOverride None
  Options None
  Order allow,deny
  Allow From All
   </Directory>

</VirtualHost>

et voilà, en sachant comment marchent les Vhosts d'apache, on se rend compte qu'il n'y a vraiment pas de quoi paniquer.

4. démarrage d'apache, test du vhost en <a href='https://serveur/' target='_blank'>https://serveur/</a> certificat accepté par le client bla bla bla...

temps de l'étape : 5 minutes

Voilà, tout commentaire sera apprécié ^_^
Celui qui détruit quelque chose pour savoir ce que c'est, a quitté le chemin de la sagesse.

Avatar de l’utilisateur
CocoVFR
Membre ancien
Membre ancien
Messages : 281
Inscription : jeu. 08 janv. 2004, 20:19

Messagepar CocoVFR » jeu. 29 juil. 2004, 13:44

Salut a tous.
Je voulais m'y mettre aussi. Sauf que mon #@[#`|\|#{| de serveur n'arrete pas de me casser les {#~|{~[ depuis avant hier. :angry:
Sinon, bravo. 15mn pour installer SSL, je serai certainement incapable de faire mieux. :P
L'informatique est un outils pour l'homme, et pas le contraire

Avatar de l’utilisateur
Guide_Gnu
Pilier de forum
Pilier de forum
Messages : 1010
Inscription : dim. 07 mars 2004, 17:37
Localisation : Quelques part dans Level3
Contact :

Messagepar Guide_Gnu » jeu. 29 juil. 2004, 13:46

intéréssent, intéréssent, tu nous compile quand Apache1.3.31/PHP5.0.0/MySQL4.0.20 pour Windows avec full option? :P

En tout cas bravo pour l'installation rapide en mod_ssl ;)
6 ans de serveurs dédiers.
1 ré-installations (vive Gentoo..).
Plus de 10To échanger sur le web !

Guest_steve

Messagepar Guest_steve » dim. 08 août 2004, 20:11

Salut a tous,

J'ai suivit ce que tu as dit, j'ai égallement trouver un tuto pour m'aider.

Par contre quand je test apache il me marque un message d'erreur il me di que le mod_ssl.so et introuvable????

pourtant je l'ai mit dans le dossier modules??

merci de votre aide
Steve

Avatar de l’utilisateur
Gandalf
Sorcier des forums
Sorcier des forums
Messages : 2528
Inscription : jeu. 04 déc. 2003, 22:58

Messagepar Gandalf » lun. 09 août 2004, 15:31

as-tu fait ça :
Puis j'ai copié ssleay32.dll et libeay32.dll dans c:/windows/system32.
?
Celui qui détruit quelque chose pour savoir ce que c'est, a quitté le chemin de la sagesse.

Avatar de l’utilisateur
Gandalf
Sorcier des forums
Sorcier des forums
Messages : 2528
Inscription : jeu. 04 déc. 2003, 22:58

Messagepar Gandalf » jeu. 16 sept. 2004, 23:23

Hello à tous,

Apache 2.0.51 étant sorti, j'ai mis à jour l'archive <a href='http://www.apachefrance.com/Telechargement/fichiers/mod_ssl-apache2.0.50-openSSL0.97d-win32.zip' target='_blank'>http://www.apachefrance.com/Telechargement...0.97d-win32.zip</a> afin d'y incorporer la dernière version de mod_ssl fournie avec cette version d'apache.

Il est recommandé d'utiliser ce nouveau module, car certains problèmes de sécurité ont été détecté dans la version précédente et corrigés dans celle-ci.
Celui qui détruit quelque chose pour savoir ce que c'est, a quitté le chemin de la sagesse.

Ju

Messagepar Ju » lun. 20 sept. 2004, 17:39

Salut!

J'ai le même problème que celui cité plus haut : "cannot load mod_ssl.so into server la procédure spécifiée est introuvable"

Pourtant j'ai copié le module, les dll

une autre idée?

merci

Avatar de l’utilisateur
Gandalf
Sorcier des forums
Sorcier des forums
Messages : 2528
Inscription : jeu. 04 déc. 2003, 22:58

Messagepar Gandalf » lun. 20 sept. 2004, 17:58

as-tu bien la dernière version d'apache 2 ?
où as tu exactement copié les dlls ? dans system32 ?
le module est dans quel répertoire ?
et comment le charges-tu dans le httpd.conf ?
Celui qui détruit quelque chose pour savoir ce que c'est, a quitté le chemin de la sagesse.

Avatar de l’utilisateur
iwsmike
Membre
Membre
Messages : 31
Inscription : mer. 08 sept. 2004, 12:03
Localisation : France
Contact :

Messagepar iwsmike » lun. 20 sept. 2004, 22:06

as-tu copié le fichier .so dans le répertoire des modules de Apache ? :D :P B)
-----------------------------------------<br>Merci, Thanks, Gracias, Danke, 谢谢

Ju

Messagepar Ju » mar. 21 sept. 2004, 8:58

J'ai copié
les dll dans C:\WINNT\system32
le modules mod_ssl.so dans E:\Apache Group\Apache2\modules

Je charge mon module comme ça :
LoadModule ssl_module modules/mod_ssl.so

mais j'ai la version 2.0.47 d'Apache :(

Avatar de l’utilisateur
Guide_Gnu
Pilier de forum
Pilier de forum
Messages : 1010
Inscription : dim. 07 mars 2004, 17:37
Localisation : Quelques part dans Level3
Contact :

Messagepar Guide_Gnu » mar. 21 sept. 2004, 9:03

mais j'ai la version 2.0.47 d'Apache

Il faut passé sur Apache 2.0.51 et il y auras plus de problème ;)
6 ans de serveurs dédiers.
1 ré-installations (vive Gentoo..).
Plus de 10To échanger sur le web !

Guest

Messagepar Guest » mar. 21 sept. 2004, 9:48

Merci, J'ai essayé avec la version 2.0.50 et plus de pb
Mais y'a quand même pas moyen avec la version 2.0.47??

Avatar de l’utilisateur
Gandalf
Sorcier des forums
Sorcier des forums
Messages : 2528
Inscription : jeu. 04 déc. 2003, 22:58

Messagepar Gandalf » mar. 28 sept. 2004, 17:12

pourquoi utiliser la version 2.0.47 qui a des bugs connus ??

PS: j'ai mis à jour mod_ssl en version 2.0.52
Celui qui détruit quelque chose pour savoir ce que c'est, a quitté le chemin de la sagesse.

Ju

Messagepar Ju » mar. 05 oct. 2004, 16:50

Oui, c'est bête, mais elle est sur un serveur de prod et c'est pas moi qui décide d'upgrader le serveur web.
Bon, j'ai trouver la bonne version d'open_ssl et tout va bien!

merci

Avatar de l’utilisateur
Apachi
Nouveau membre
Messages : 5
Inscription : jeu. 07 oct. 2004, 17:48

Messagepar Apachi » jeu. 07 oct. 2004, 17:52

Après avoir suivi la procédure j'obtient un "[warn] Init: Session Cache is not configured [hint: SSLSessionCache]" dans le log.

netstat -an montre que le port 443 n'est pas en écoute. :huh:

Une idée ?

Thx


Revenir vers « Installation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités