[Résolu] Apache et mod_ssl

Questions sur l'installation d'Apache/PHP/MySQL.

Modérateur : Modérateurs

hannibal
Nouveau membre
Messages : 3
Inscription : mar. 14 juin 2011, 17:58

[Résolu] Apache et mod_ssl

Messagepar hannibal » lun. 20 juin 2011, 17:48

Bonjour a tous,

je suis en train d'installer mon serveur apache a partir des sources (sur une debian squeeze x86).
Malheureusement j'ai un petit soucis avec openSSL lorsque je tente de lancer mon serveur apache.
Voici l'erreur:

Code : Tout sélectionner

httpd: Syntax error on line 83 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/mod_ssl.so into server: libssl.so.1.0.0: cannot open shared object file: No such file or directory


Et voici la ligne en cause:

Code : Tout sélectionner

 LoadModule ssl_module modules/mod_ssl.so


Je ne comprend pas d'ou vient l'erreur vue que je configure la compilation de apache ainsi:

Code : Tout sélectionner

./configure --enable-ssl -with-ssl=/usr/local/ssl/ --enable-rewrite  --enable-mods-shared=most --with-layout-Apache


Voici les ligne du configure correspondant a ssl:

Code : Tout sélectionner

checking whether to enable mod_ssl... checking dependencies
checking for SSL/TLS toolkit base... /usr/local/ssl
  adding "-I/usr/local/ssl/include" to CPPFLAGS
  adding "-I/usr/local/ssl/include" to INCLUDES
  adding "-L/usr/local/ssl/lib" to LDFLAGS
checking for OpenSSL version... checking openssl/opensslv.h usability... yes
checking openssl/opensslv.h presence... yes
checking for openssl/opensslv.h... yes
checking openssl/ssl.h usability... yes
checking openssl/ssl.h presence... yes
checking for openssl/ssl.h... yes
OK
  forcing SSL_LIBS to "-lssl -lcrypto  -lrt -lcrypt  -lpthread -ldl"
  adding "-lssl" to LIBS
  adding "-lcrypto" to LIBS
  adding "-lrt" to LIBS
  adding "-lcrypt" to LIBS
  adding "-lpthread" to LIBS
  adding "-ldl" to LIBS
checking openssl/engine.h usability... yes
checking openssl/engine.h presence... yes
checking for openssl/engine.h... yes
checking for SSLeay_version... yes
checking for SSL_CTX_new... yes
checking for ENGINE_init... yes
checking for ENGINE_load_builtin_engines... yes
checking for SSL_set_cert_store... no
  forcing MOD_SSL_LDADD to "$(SSL_LIBS)"
checking whether Distcache is required... no (default)
  adding "-export-symbols-regex" to MOD_SSL_LDADD
  adding "ssl_module" to MOD_SSL_LDADD
checking whether to enable mod_ssl... shared (most)
  adding "-I$(top_srcdir)/modules/ssl" to INCLUDES



Et voici un ll /usr/local/ssl

Code : Tout sélectionner

ll /usr/local/ssl/
total 40
drwxr-sr-x 2 root staff  4096 20 juin  17:05 bin
drwxr-sr-x 2 root staff  4096 20 juin  17:05 certs
drwxr-sr-x 3 root staff  4096 20 juin  17:05 include
drwxr-sr-x 4 root staff  4096 20 juin  17:05 lib
drwxr-sr-x 6 root staff  4096 20 juin  17:05 man
drwxr-sr-x 2 root staff  4096 20 juin  17:05 misc
-rw-r--r-- 1 root staff 10819 20 juin  17:05 openssl.cnf
drwxr-sr-x 2 root staff  4096 20 juin  17:05 private


J'ai donc bien openSSL d'installer en /usr/local/ssl.


Une idée pour résoudre mon problème ?

Merci d'avance pour votre aide ;)
Dernière édition par hannibal le lun. 20 juin 2011, 18:09, édité 1 fois.

hannibal
Nouveau membre
Messages : 3
Inscription : mar. 14 juin 2011, 17:58

Re: [Prob] Apache et mod_ssl

Messagepar hannibal » lun. 20 juin 2011, 18:09

Résolu, le probleme venait de la lib openSSL qui avait été mal compiler ;)


Revenir vers « Installation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités